Get in touch
Back
Maintenance

System upgrade

Completed 21 Aug at 05:00pm CEST.

Frontend Login API
Completed

Maintenance completed

Posted 21 Aug at 05:00pm CEST.
Started

A system upgrade is planned between 13:30 and 17:00 which might result in some minutes of downtime.

Posted 21 Aug at 01:30pm CEST.